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„Definícia štatistiky: Je to veda, ktorá 
vyrába nespoľahlivé fakty zo spoľahlivých 
údajov.“

Evan Esar

„Ak váš experiment potrebuje 
štatistiku, znamená to, že ste  mali 
urobiť lepší experiment.“

Ernest Rutherford
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Je dokázané, že oslavovanie narodenín 
je zdravé.

Štatistiky ukazujú, že ľudia, ktorí 
oslávili najviac narodenín žili 
najdlhšie.

S. den Hartog
Ph D. Thesis Universtity of Groningen
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O čom budeme hovoriť?
� Premenné
� Hypotézy
� Štatistická signifikancia
� Frekvencie
� Deskripcia/inferencia
� Rozptyl
� Variancia
� Distribúcia
� Korelácia
� Regresia
� atď.
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Úrovne merania
� nominálna, ordinálna , kardinálna (intervalová a pomerová)
� Nominálne premenné:

� Nedajú sa zoradiť podľa veľkosti, platí pravidlo patrí/nepatrí
� (pohlavie, typ diagnózy, miesto bydliska, ...)

� Ordinálne (poradové) premenné: 
� Majú nepresné/nerovnaké vzdialenosti medzi po sebe nasledujúcimi hodnotami, ale  ich 

poradie odráža postupný nárast/pokles parametra
� (Lickertova škála: miera súhlasu, frekvencia: nikdy, niekedy, občas, často, vždy)

� Intervalové premenné:
� majú rovnaké vzdialenosti medzi jednotlivými hodnotami, ale nulové hodnoty sú len 

dohodnuté (arbitrárne stanovené) 
� (napr. teplota v stupňoch Ceslia/Farenheita, IQ,...).

� Pomerové premenné: 
� majú reálnu nulovú hodnotu a definované rovnaké vzdialenosti medzi jednotlivými 

hodnotami
� umožňujú najväčšiu flexibilitu štatistických metód a môžu byť použité pre analýzy
� (reakčný čas, hmotnosť, dĺžka, ...)

� Kategorické premenné: nominálne a ordinálne
� Kontinuálne premenné: pomerové a intervalové premenné
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Typ škály
Matematická 

štruktúra
Prípustné štatistické operácie

Prijateľné 
transformácie

Nominálna
Kategorická

Nezoradená množina modus, Chi-kvadrát
One to One
(equality (=))

Ordinálna
(poradová)

Zoradená množine

medián and modus, percentily, 
poradová korelácia (Spearman‘s rho), 
neparametrická analýza variancie,

Monotonic
increasing
(order (<))

Intervalová
Nekonečné 
kontinuum

priemer, standardná odchýlka, korelácia
(Pearson‘s r), regresia, parametrická 
analýza variancie, factorová analýza

Positive linear
(affine)

Pomerová
Jednorozmerný
vektorový priestor

All statistics permitted for interval scales 
plus the following: geometric mean, 
harmonic mean, coefficient of variation, 
logarithms

Positive
similarities
(multiplication)

Stanley Smith Stevens
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Deskripcia/Inferencia?
� Deskriptívna štatistika:

� Číselný a grafický opis súboru
� prevalencie, proporcie, priemery, kategórie,... (grafy, 

tabuľky)

� Inferenčná štatistika:
� vyvodzovanie vzťahov a súvislostí, hľadanie rozdielov 

(testy, korelácie, ...)
� Testovanie hypotéz (áno/nie)
� Popis vzťahov (korelácia)
� Modelovanie vzťahov (regresná analýza)

Signifikancia
� Štatistická významnosť

� udáva s akým rizikom (pravdepodobnosťou) zamietame 
nulovú hypotézu v prípade, keby bola pravdivá.

� Nehovorí o závažnosti zisteného rozdielu/vzťahu

� Vyjadruje sa ako p-hodnota (nehovorí i miere efektu)

� vysoko signifikantný výsledok nemusí mať žiaden 
praktický význam

� Súvisí s veľkosťou vzorky (sample size)
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Chyby štatistických záverov
� Ak výsledok testu zodpovedá realite, potom je 

rozhodnutie správne, ak nie potom došlo k chybe.

� Kvôli štatistickej povahe testu, výsledok, až na pár 
zriedkavých výnimiek, nie je nikdy bez chyby

� Rozlišujeme  2 druhy chýb: 
� Chyba I. typu (type I error)

� Chyba II. typu (type II error)

Chyba I. typu
� chybné zamietnutie nulovej hypotézy

� nastane, keď nulová hypotéza (H0) je pravdivá, ale je 
zamietnutá

� Chyba falošnej pozitivity (planý poplach/false
alarm) je výsledok, ktorý naznačuje, že daná 
podmienka bola splnená, aj keď v skutočnosti splnená 
nebola.

� Uvádza sa ako signifikancia testu (α) = 
pravdepodobnosť výskytu chyby I. typu
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Chyba II. typu
� nesprávne prijatie nulovej hypotézy

� Nulová hypotéza je nesprávna, ale na základe testu je 
nemožno zamietnuť

� Chyba falošnej negativity

� Označuje sa ako Beta (β), súvisí so „silou“ testu = (1 -
β)

� Štatističky test umožní prijať/zamietnuť H0, ale nikdy 
nedokážejej pravdivosť/nepravdivosť

Ho je pravdivá Ho je nepravdivá

Zamietnutie H0
Chyba I. typu

(Falošná pozitivita)

Správny záver
(skutočná pozitivita)

Nezamietnutie H0
Správny záver

(skutočná negativita)
Chyba II. Typu

(Falošná negativita)
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“Štatistika nikdy nemôže nahradiť 
zdravý úsudok“

Henry Clay

Signifikancia
� Vecná signifikancia – effekt size (miera efektu)

� Cohenovo d, odds ratio (OR)

d=0,2 – 0,3 malý efekt
d=okolo 0,5  stredne veľký efekt
d > 0,8 veľký efekt
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Signifikancia
� Power analyses (G*Power – nie je SPSS)

� Resp. udáva akú veľkú mieru efektu vieme odhaliť na 
danej vzorke

� Výpočet minimálnej veľkosti vzorky potrebnej pre 
spoľahlivé odhalenie/detekciu stanovenej miery efektu

� Umožňuje správne zamietnutie/prijatie nulovej 
hypotézy

� Štandardne by nemala byť nižšia ako 0,80

Veľkosť vzorky v závislosti na pomere  S/N (5% sig., 2-sided)

Signal/Noise
ratio

90% power 80% power

0.2 526 393
0.4 132 99
0.6 59 45

0.8 34 26
1.0 22 17
1.2 16 12
1.4 12 9
1.6 9 7
1.8 8 6
2.0 6 5
2.2 6 4
2.4 5 4
2.6 4 4
2.8 4 3
3.0 4 3
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Interpretácia výsledkov
� Nie len prijatie/zamietnutie nulovej hypotézy

� Úroveň signifikancie

� Zhodnotenie reálnych rozdielov/vzťahov

� Zohľadniť charakteristiky testovaného súboru 
(kontext) – súčasť diskusie
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� Vytvorenie premenných
� Pohlavie, vek, ... Položky škál alebo škálové skóre,...
� Missing values
� import z Excelu?

� Definovanie vlastností a hodnôt premennej:
� číselná, dátum, reťazec textu,...
� Nominálna, ordinálna, kardinálna (škálová)
� Názov a popis premennej
� Definovanie hodnôt (čo ktoré číslo znamená)

� Úprava premenných
� Výpočet skóre škál, transformácia hodnôt, rekódovanie, 

dichotomizácia
� Definovanie súborov premenných pre analýzy

Úprava premenných
� Výpočet skóre škál

� Transformácia hodnôt – z-skóre

� Rekódovanie hodnôt, dichotomizácia

� Definovanie súborov premenných

Ako na to v SPSS:
Transform -> Compute variable -> položka1 + položka 2 +....+ položka n - OK

Ako na to v SPSS:
Analyze -> Descriptive statistics-> Descriptives: √ Save standardized value as variables -OK

Ako na to v SPSS:
Transform -> Recode into Different variable: položka1 -> Old and new values ...

Ako na to v SPSS:
Utilities -> Define Variable sets -> Názov nového setu -> položka1 + položka 2 +....+ 
položka n – OK .....Use variable sets
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Vedeli ste, že veľká väčšina ľudí má 
viac ako priemerný počet nôh?
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„Priemerný Austrálčan má jeden 
semenník a jeden prsník a menej ako 
dve nohy!“
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Popis súboru
� Frekvenčné tabuľky

Ako na to v SPSS:
Analyze -> Descriptive statistics -> 
Frequencies: √ Display frequency
tables
• Statistics: priemer, medián, 

modus, std. odchýlka, rozptyl, 
rozsah, šikmosť/strmosť 
distrbúcie

• Charts: stĺpcový graf, koláčový 
graf, histogram



18. 1. 2013

19

Popis súboru
� Miery centrálnej tendencie:

� Modus – najčastejšie sa vyskytujúca hodnota

� Medián – polohový stred, 50-ty percentil

� Priemer – aritmetický priemer

� Nominálne premenné: modus

� Ordinálne premenné: modus, medián

� Kardinálne premenné: modus, medián, priemer

Popis súboru
� Distribúcia

� Štandardná odchýlka 
(sigma, σ; SD) – rozptyl 
hodnôt okolo priemeru

� Šikmosť (skewness) 
distribúcie

� Strmosť (kurtosis) 
distribúcie (vydutie)
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Popis súboru
� Grafy

� Stĺpcový graf

� Čiarový graf

� Koláčový graf

� Bodový graf (scatter plot)

� Histogram

� Boxplot

Ako na to v SPSS:
Graphs -> Chart Builder:

Stĺpcový graf
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Histogram

Boxplot
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Boxplot - vysvetlenie

{Medzikvartilové
rozpätie (IQR)

Medián
(polohový stred)

Fúzy (whiskers)
do +/- 1,5 násobok IQR

Vybočujúce hodnoty 
(outliers) 

(+/- 1,5 -3 násobok IQR) 

Boxplot - vysvetlenie

Extrémne 
hodnoty

nad +/- 3 násobok 
IQR
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Združený boxplot

„Eye-ball test“
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Scatter plot

Stratifikácia súboru
� Členenie na podskupiny

� Umožňuje simultánnu analýzu podskupín (muži, ženy, 
a pod) – split file

� Môžeme tiež analyzovať len jednu podskupinu (len 
muži, len 11-roční) – select cases

Ako na to v SPSS:
Data -> Split File alebo Select Cases
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� Proporcia chlapcov a dievčat len v skupine 15-ročných
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Príklad umenia deskripcie

� Hans Rosling (TED talks)

So štatistikou je to ako s príbehom o 
obchodníkovi, ktorého sa pýtali, ako môže 
predávať králičie sendviče tak lacno. "No," 
vysvetľoval, "musím do nich tiež dať aj 
nejaký ten kúsok konského mäsa.

Ale miešam to 50:50. Jeden kôň, jeden 
králik."

Darrel Huff
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Porovnávanie 2 a viacerých 
súborov
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Rozdiely (nominálna úroveň)
� Pearsonov Chi kvadrát

Ako na to v SPSS:
Analyze -> Descriptive statistics-> Crosstabs: Statistics √ Chi square - OK

Výskumná otázka:
Majú viac sexuálnych skúseností 
dievčatá alebo chlapci?
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Rozdiely (nominálna úroveň)
� Pearsonov Chi kvadrát

Záver: Chlapci a dievčatá sa nelíšia v sexuálnych skúsenostiach

�Obrázok piva Guiness



18. 1. 2013

32

�Obrázok piva Guiness

Studentov t-test
(kardinálna úroveň)
� 1908 – Guiness brewery (William 

Sealy Gosset)
� Lacný spôsob monitorovania kvality 

piva
� t-test pre 2 nezávislé výbery, závislé 

výbery, ...
� Porovnáva vždy len 2 súbory
� Parametrický test
Parametre:
� Normalita distribúcie (Gaussová

krivka)
� Homoscedasticita – homogenita, 

rovnosť rozptylov
Ako na to v SPSS:
Analyze -> Compare Means -> Independent sample t-test: Variables, Define groups - OK

Studentov t-test
� Normalita distribúcie
� Overujeme ju:

� Kolmogorov-Smirnov test –
neparametrický test

� Shapiro-Wilk test
� H0 – populácia je normálne 

rozložená
� Ak zamietneme H0, 

nemali by sme pokračovať 
v t-teste

Ako na to v SPSS:
Analyze -> Desriptive stat. -> 
Explore – Plots: √ Normality plots
with tests - OK
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Overenie normality distribúcie

Ako na to v SPSS:
Analyze -> Desriptive stat. -> Explore – Plots: √ Normality plots with tests - OK

Overenie normality distribúcie

Záver: Prijímame H0 o normálnej 
distribúcii hodnôt v populácii (aj u 
mužov aj u žien)
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Overenie normality distribúcie

Studentov t-test
� Homoskedasticita

� Overujeme ju:
� Levenov test rovnosti 

rozptylov (súčasť t-
testu v SPSS)

� H0 – rozptyly 

� t-test produkuje 
výsledky  pre prípad 
prijatia aj zamietnutia 
H0
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Studentov t-test

Ako na to v SPSS:
Analyze -> Compare Means -> Independent sample t-test: Variables, Define groups - OK

Studentov t-test

Záver: Muži a ženy sa nelíšia v úrovni náboženského fundamentalizmu
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Studentov t-test
� V prípade nenormálne distribuovaných dát môžeme 

rozdiely medzi skupinami testovať neparametrickou 
alternatívou – U-test

Rozdiely (ordinálna úroveň)
� Mann-Whitneyho U-test

Ako na to v SPSS:
Analyze -> Nonparametsic tests -> Legacy dialogs -> 2 independent samples √ Mann-
Whitne U - OK

Výskumná otázka:
Líšia sa dievčatá a chlapci v počte 
vyfajčených cigariet za týždeň?
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Overenie normality distribúcie

Ako na to v SPSS:
Analyze -> Desriptive stat. -> Explore – Plots: √ Normality plots with tests - OK

Overenie normality distribúcie

Záver: Zamietame H0 o normálnej distribúcii hodnôt v populácii
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Overenie normality distribúcie

Rozdiely (ordinálna úroveň)

Záver: Nie je rozdiel v počte vyfajčených cigariet medzi chlapcami a dievčatami
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ANOVA
� Jednoduchá analýza rozptylu (analysis of variance)

� Umožňuje testovať rozdiely u 3 a viac populácií naraz
Ako na to v SPSS:
Analyze -> Compare Means -> One-Way ANOVA: Dependent List, Factor- OK

Výskumná otázka:
Je rozdiel v telesnej hmotnosti 
medzi žiakmi v jednotlivých 
vekových kategóriách?

ANOVA
� Post-Hoc testy – párové porovnania
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ANOVA
� Post-Hoc testy – párové porovnania

ANOVA
� Neparametrická alternatíva:

� Kruskal-Wallis test 

� Neobsahuje Post-Hoc testy

� Párové porovnanie je potrebné urobiť U-testom pre každú 
dvojicu

� Friedman test (nie je v SPSS)

Ako na to v SPSS:
Analyze -> Nonparametsic tests -> Legacy dialogs -> K independent samples √ Kruskal-
Wallis H - OK
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Kruskal-Wallis test
Výskumná otázka:
Je rozdiel medzi žiakmi v jednotlivých vekových kategóriách v počte vyfajčených cigariet za 
týždeň?

Kruskal-Wallis test
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Analýza vzťahov medzi 
premennými

Korelácie
� Pearsonova korelácia (koeficient r)

� r nadobúda hodnoty od -1 po +1
� -1 negatívna asociácia (nepriama úmera)
� +1 pozitívna asociácia (priama úmera)
� kardinálna vs. kardinálna premenná (napr. hrubé skóre)

� Interpretácia koeficentu
� Úrovne sú stanovené arbitrárne, nemali by byť chápané veľmi striktne
� Interpretácia závisí od kontextu a zámeru (vo fyzike je mála aj r=0.9)
� Nemožno hovoriť o kauzalite

Sila vzťahu/korelácie Negatívne 
hodnoty

Pozitívne  
hodnoty

Žiaden vzťah -0.09 do 0.0 0.0 do 0.09

Malá -0.3 do -0.1 0.1 do 0.3

Stredná -0.5 do -0.3 0.3 do 0.5

silná -1.0 do -0.5 0.5 do 1.0
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Korelácie
� Vzťah premenných v grafickej a číselnej podobe (r koeficient)

Korelácie



18. 1. 2013

44

Korelácie
� Spearmanove Rho (ρ)

� poradová korelácia
� Rho nadobúda hodnoty od -1 po +1
� ordinálna vs. ordinálna premenná
� ordinálna vs. kardinálna premenná

� Parciálne korelácie
� Umožňujú „očistiť“ koreláciu 2 premenných o podiel 

interferujúcej premennej

Ako na to v SPSS:
Analyze -> Correlate -> Bivariate: Variables, √ Pearson/Spearman- OK

Korelácie Výskumná otázka:
Existuje súvislosť medzi vekom a výškou  respondenta?
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Regresná analýza
� Umožňuje odhadnúť vzťahy medzi premennými

� Techniky modelovania

� Jedna závislá, jedna alebo viac nezávislých 
(vysvetľujúcich) premenných

� Umožňuje predikciu zmien závislej premennej v 
prípade, že dôjde k zmene v nezávislých premenných

� Za špecifických podmienok môžeme usudzovať o 
kauzálnom vzťahu (inak len experiment)
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Regresná analýza
� Druhy:

� Lineárna
� (nezávislá premenná: 

kardinálna)

� Logistická
� (nezávislá premenná: 

dichotomická)

� Multinomiálna
� (nezávislá premenná: 

kategorická, 3 a viac kategórií)

� Pojmy:
� Crude effect

� Adjusted effect

� Moderácia (interakcia)

� Mediácia

� Skreslenie (confounding)

� Skreslenie (bias) – závisí 
od dizajnu štúdie a 
faktormi súvisiacimi so 
získavaním údajov 

Vysvetľujúca premenná
Závislá premenná

(outcome)

Mediátor

Moderátor

Skreslenie
(confounding)

(crude effect)
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Skreslenie (confounding)
� 1.) prediktor (A) a confounder (B) musia byť prepojený 

so závislou premennou (C)

� 2.) prediktor a confounder musia byť prepojený 
(interkorelácia)

� 3.) skreslenie nesmie byť kauzálnym následkom 
prediktora

B

A C

M.A. Babyak: Understanding confounding and mediation. Evid Based Mental Health 

2009 12: 68-71

Mediácia
� Sprostredkujúci efekt
� Matematicky sa nelíši od confoundingu
� 1.) prediktor (A) a mediátor (B) musia byť prepojený so závislou 

premennou (C)
� 2.) prediktor a mediátor musia byť prepojený (interkorelácia)

� 3.) skreslenie musí byť kauzálnym následkom prediktora (A 
zapríčiňuje B)

B

A Cx
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Mediácia a Skreslenie
� Adjustácia na moderátor/confounder

� zníženie alebo eliminácia efektu A na C (pokles OR, 
alebo aj strata signifikancie)

� Príklad mediácie: 
� Stres -> fajčenie -> rakovina

� Obezita -> cholesterol -> vysoký krvný tlak

� Etnicita (Róm) -> nižšie vzdelanie -> horšie zdravie

� Príklad skreslenia: 
� Pitie kávy -> infarkt myokardu (conf. fajčenie)

Moderácia
� Ak vzťah dvoch premenných závisí od úrovne tretej 

premennej

� Úroveň moderátora ovplyvňuje mení vzťah 2 
premenných

� Častý moderátor:
� Pohlavie, etnicita, rasa,....

Napr. : Aspirín -> zníženie rizika infarktu (ale len u 
mužov)
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Moderácia
� Zisťuje sa inrakciou dvoch prediktorov (napr. etnicita a 

pohlavie)

� Do analýzy zadáme:
� Prediktor 1

� Prediktor 2

� Prediktor 1 * Prediktor 2

� Ak je interakcia signifikantná je vhodné stratifikovať 
analýzy (osobitne analyzovať mužov a osobitne ženy)

Lineárna regresia

Ako na to v SPSS:
Analyze -> Regression -> Linear...

Výskumná otázka:
Má vek respondenta vplyv na množstvo týždenne vyfajčených cigariet?
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Lineárna regresia – crude effect

Záver: Vek respondenta vysvetľuje množstvo týždenne vyfajčených cigariet. Čím 
vyšší vek, tým viac vyfajčených cigariet žiaci udávajú.

Lineárna regresia – adjusted effect
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Lineárna regresia – kategorizovaný prediktor

� Môžeme zadať aj kategoriuckú premennú, ale len v 
podobe 0/1 (dichotomická)

� Pohlavie (1 muž, 0 žena) (0 je referenčná kategória)

� Pri multikategoriálnych premenných musíme vytvoriť 
tzv. „dummy variables“
� Napr. vzdelanie: ZŠ=1, SŠ=2, VŠ=3

� Transformácia:
� ak referenčná kategória ZŠ

� Rekódujeme premenné:

vzdelanie Hodnota v 
databáze
(dummy SŠ)

Hodnota v 
databáze
(dummy VŠ)

ZŠ 0 0

SŠ 1 0

VŠ 0 1

Lineárna regresia

Veková skupina Hodnota v 
databáze
(dummy SŠ)

Hodnota v 
databáze
(dummy VŠ)

11-roční 0 0

13-roční 1 0

15-roční 0 1
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Lineárna regresia

Žiaci v skupine 15-ročných s 
vyššou pravdepodobnosťou 

fajčia viac cigariet ako 11-
roční žiaci

Binárna logistická regresia
� Závislou premennou môže byť len dichotomická premenná 

(0/1)

� Diagnóza (napr. má depresiu=1, nemá depresiu=0)

� Pozor na kódovanie! (riziko opačných výsledkov)

� Vysvetľujúce premenné môžu byť kategorickej alebo 
kontinuálnej povahy (potrebné zadefinovať)

� Pri definovaní kategorickej povahy si môžeme vybrať 
referenčnú kategóriu (na rozdiel od lineárnej regresie, 
nemusíme už vytvárať „dummy variables“ – deje sa to 
automaticky)

Ako na to v SPSS:
Analyze -> Regression -> Binary Logistic....



18. 1. 2013

53

Binárna logistická regresia
Výskumná otázka:
Má pohlavie respondenta 
súvislosť so sexuálnou 
skúsenosťou?

Binárna logistická regresia
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Binárna logistická regresia

Záver 1: Pohlavie respondenta nesúvisí so sexuálnou skúsenosťou (nie je 
prediktorom)?

Záver 2: BMI respondenta nesúvisí so sexuálnou skúsenosťou (nie je 
prediktorom)?

Binárna logistická regresia
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Faktorová analýza
� Na základe analýzy variability pozorovaných premenných 

abstrahuje latentné – nepozorované premenné

� pozorované premenné odrážajú variáciu menšieho počtu 
latentných premenných

� Latentné premenné – faktory

� FA vychádza z analýzy hlavných komponentov (Principal
component analysis, PCA)

� Psychologická metóda :D
� Charsles Spearmen – výskum inteligencie (g faktor)

� Raymond Cattel – osobnostný dotazník 16PF
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Faktorová analýza
� Vychádza z korelácií (korelačná matica)

� Determinant korelačnej matice (nad 0,00001)

� Keiser-Meier-Olkinova miera adekvátnosti výberu 
(nad 0,7)

� Bartlettov test sféricity: potrebujeme zamietnuť H0 
(sig. < 0,05)

� Nesplnenie podmienok značí, že dáta nie sú vhodné na 
faktorovú analýzu

Ako na to v SPSS:
Analyze -> Dimension reduction -> Factor ...
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Faktorová analýza
� Počet faktorov závisí:

� Eigenvalue (vlastná hodnota) nad 1.0

� Definovaním počtu faktorov

� Percentom vysvetlenej variancie

� Posúdením sutinového grafu (scree plot)

� Rotácia – zlepšuje utriedenie položiek a tým interpretáciu 
faktorov (v porovnaní s nerotovaným riešením)

� Pomenovanie výsledných faktorov je tvorivá činnosť
� Snaha vystihnúť spoločné znaky premenných vo faktore

Faktorová analýza
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Odhad reliability
� Reliabilita = spoľahlivosť merania

� Reliabilita ako interná konzistencia testu (split-half, 
paralelné formy, Cronbach alfa) alebo stabilita v čase 
(test-retest)

� Test retest (korelácia)

� Split-half

� Paralelné formy

� Cronbachove α (vhodné nad 0,70)
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Ako na to v SPSS:
Analyze -> Scale -> Reliability analysis ...
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"Existujú tri druhy lží: lži, sakramentské 
lži a štatistiky"

Mark Twain

„Fakty sú neúprosné, ale štatistiky sú 
prispôsobivejšie.“

Mark Twain
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Štatistika je ako bikiny – to čo odhaľuje 
je síce uchvacujúce, ale to čo zakrýva je 
rozhodujúce. 

Aaron Levenstein

„Ja verím len štatistikám, ktoré som si 
sám sfalšoval."

Winston S. Churchill
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Skreslenia výsledkov
� Zámerné/nezámerné, náhodné

� Hľadanie spôsobov ako interpretovať len údaje, ktoré 
sú priaznivé pre prezentujúceho

� Falošné štatistiky – poškodzujú hľadanie poznania 
(náprava môže trvať desaťročia, stáť veľa 
peňazí/životov)

� Preosievanie dát/fishing
� hľadanie vzťahov a rozdielov, bez vopred stanoveného 

zámeru, hypotézy
� 5% šanca nájdenia korelácie medzi 2 náhodnými 

premennými
� Manipulácia s dátami 

� selektívne reportovanie (uprednostňovanie výsledkov ktoré 
podporujú preferovanú hypotézu a ignorovanie 
protirečiacich; napr. experimenty s ESP)

� vyrábanie falošných dát (exProf. Diederik Stapel – sociány
psychológ, NL, 2011, priznal sa k manipulácii dát po niekoľko 
rokov)
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„Štatistiku často používame ako, keď 
opitý človek používa stĺpy kandelábrov 
– skôr pre  svoju oporu než pre 
osvetlenie.“

Andrew Lang

„Štatistikou viem dokázať čokoľvek 
okrem pravdy.“

George Canning
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Problémové učenie

Problémové učenie
� Úloha 1:

a) Vypočítajte vek respondentov z mesiaca a roku 
narodenia, ku šiestemu mesiacu roku 2010 (príkaz 
compute)

b) Kategorizujte kontinuálnu premennú veku do 3 
kategórií 11-, 13- a 15-ročných (príkaz recode into
different variable)
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Problémové učenie
� Úloha 2:

� Vypočítajte hrubé skóre škály FAS (príkaz compute)

(položky FAS.1-4)

Problémové učenie
� Úloha 3:

� Vytvorte premennú, ktorá by rozdeľovala 
respondentov na tých ktorí pijú alkohol (akýkoľvek) 
aspoň raz týždenne a tých, ktorý ho pijú menej často 
alebo vôbec – dichotomizácia (compute/recode)
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Problémové učenie
� Úloha 4:
a) Popíšte súbor štúdie HBSC

� Pohlavie (N, %)
� Vek (priemer, SD)
� Skóre FAS (priemer, SD, medián, modus, range)
� Pije/nepije alkohol (N, %)

b) Popíšte vekové podskupiny (11, 13, 15-ročných)
� Pohlavie (N, %)
� Vek (priemer, SD)
� Skóre FAS (priemer, SD, medián, modus, range)
� Pije/nepije alkohol (N, %)

Problémové učenie
� Úloha 5:

� Vytvorte graf:
� Koláčový pre pohlavie

� Histogram a boxplot pre vek

� Histogram a boxplot pre skóre FAS
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Problémové učenie
� Úloha 6:

a) Existuje rozdiel v úrovni bohatstva (FAS) u tých 
ktorý pijú akýkoľvek alkohol aspoň raz týždenne 
a tými, ktorý ho pijú menej často/vôbec?

b) Vytvorte boxplot pre skóre FAS stratifikovaný 
podľa dichotomizovanej premennej pitia 
alkoholu

Problémové učenie
� Úloha 7:

� Líšia sa respondenti v jednotlivých vekových 
kategóriách (11, 13, 15-roční) v úrovni rodinného 
blahobytu vyjadrenom škálou FAS? Ak áno, tak medzi 
ktorými dvojicami vekových kategórií je rozdiel.
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Problémové učenie
� Úloha 8:

a) Overte internú konzistenciu škál:
� SROS, S. fundamentalizmu, S. ortodoxnosti, Levenson

LOC, R. saliencie, S. zivotnej spokojnosti, God mediated
control, Depresivita, Self-esteem

b) Vypočítajte ich hrubé skóre, v prípade 
viacdimenzinálnych škál – skóre pre subškály

c) Overte faktorovú štruktúru škál SROS, Levenson
LOC, Self-esteem, S. fundamentalizmu

Problémové učenie
� Úloha 9:
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Problémové učenie
� Úloha 10:


